PDA

View Full Version : Just got a dsi



shagnasty
02-12-2010, 09:10 PM
I just got myself a dsi with 1.4u firmware. I was wondering what flash carts are compatible with it if any. And if there is any thing else I should know.

Any help is greatly appreciated.

edrubb
02-13-2010, 10:03 AM
EZflash Vi, AceKard 2i, TTDSi, and R4DSi are all supposed to be compatible. I plan to get the R4 myself once I buy the DSi for my wife. It's the cheapest out of the options, that I've seen so far, and it seems to have the exact same features as the rest of them. Unfortunately I can't tell you more than that at this point. :o

Cybeast Falzar
02-14-2010, 02:29 PM
Anything R4 is fake. Get a Supercard DS Onei, they just made a new OS for it, making it way better, and it gets updates a lot.

kcvfr400
02-14-2010, 03:08 PM
I have always found anything by the makers of acekard or m3 products to be good. Would avoid at all cost anything R4 as it gets cloned and the compatability updates stop for new games. So a waste of money in the end.

All4consoles-UK
02-14-2010, 03:44 PM
However almost "i" variant flashcards are compatible going for one with updateabe boot is great as this can accomodate a patch for future dsi firmware updates..be aware that DSi XL is out next month so the firmware might be in the offing to be updated just before its launch..iEdge is the very latest card for a DSi and its great just like an edge ds for a ds. acekard 2i , supercard dsi , m3i zero are brilliant too..

Cybeast Falzar
02-15-2010, 11:12 AM
Just got my Supercard DS Onei, awesome. It has a USB firmware writer so if Nintendo blocks flashcards, you don't have to worry one bit. And their new OS is amazing, WAYYYYY faster and better than before, and it's just the BETA, I'll bet it'll be better than Sakura by the time it's finished, and there are constant updates.