PDA

View Full Version : Hitachi help, please.



thumperfbc
04-05-2011, 02:19 AM
Hi all, first post here. I am hoping that you can help me climb over this wall I have struck.

I am attempting to fix a buddies 360 that is showing the error that basically says "Put this disc in a xbox 360 to play it" blah blah blah.

After doing my initial research I found several possible causes, so I started tackling them. The drive in question is a Hitachi GDR-3120L, ROM version 0079FL.

So, the first thing I did was disassemble to xbox, and then the drive, in order to clean it out. Using compressed air, a shop vac, and a tiny bit of rubbing alcohol on the lens I made sure the drive was squeeky clean. Reassembled and found that nothing had changed. The problem persists.

Next, I replaced the laser lens assembly with a new unit ordered off amazon. The swap was super easy and I thought for sure it would work. I was wrong. No joy, the problem remains.

Now, I have my own 360 which recently RROD'd for the second time. When it RROD'd the first time I replaced the xclamps and used the washers and all that. It fixed my rrod, somewhat, and lasted a few months before rrod again. My xbox happens to have Hitachi drive, ROM version 0046DH. From my research it seemed that I should be able to take my known good drive and swap the pc boards. So I took my drive from my 360, put the pcb in from the bad drive, and reassembled. I just KNEW this would fix it. It didn't. The problem persists.

Next, I broke out my multimeter and adjusted the pot on the laser. I adjusted from 4500 down to about 3400. I was absolutely sure t hat I'd fixed it this time. I was wrong again. I should mention, though, that at this time the original PCB is back in place.

So, now I've hit the wall. I don't know what else to try. This xbox has had multiple owners and the warranty sticker was NOT intact when I opened the case the first time. However, it doesn't appear to have had an xclamp replacement done. That all looks factory. That makes me think that someone tried to mod the drive to play 'backups' at some point and probably screwed it up. So, if this happened, and if they saved a backup of the original firmware, it's long gone.

What can I do now? Can I pull the key from the broken drive somehow and push it onto my pcb and use that drive?

Any help would be GREATLY appreciated.

Thanks to all for wading through my mess of troubleshooting.

saleem
04-05-2011, 07:54 AM
sounds like the TO PLAY THIS DISC error might not be related to the laser,if you know the laser was good and if the console had been tampered with before could be the drive is either without key or contains incorrect key.easy way to be sure is read the firmware off the drive and use a working replacement,get a drive you know works 100% and fit that to the console.

means you have to put firmware key and spoof if necessary so the drive is married,if problem persists then the drive key is not right,only think you can do is jtag,if console aint jtaggable you have a total loss console.

rrod console,just throw it in the bin and replace with a working secondhand or new one.
:)

thumperfbc
04-05-2011, 01:01 PM
I am willing to just right-off my own RROD, so I don't mind using it's dvd drive if someone can show me how to read and flash firmware and all that jazz. I've never done that before.

I plan on replacing mine with a new style...

Any help in reading the keys would be great. :)

saleem
04-05-2011, 05:29 PM
get jungleflasher user guide,cos you need the key from the hitachi,read about getting the firmware and key off hitachi and then when you know the type of drive you will be using for replacement,read how to flash that drive,you need to read about spoofing but,jungleflasher will do that automaticaly anyway.
:)

thumperfbc
04-05-2011, 08:07 PM
Ok, so I need to interface the drives with my PC. My PC motherboard has an open SATA slot. Will that work or do I need something in particular? Where does one typically get the power adapter? I notice it is a non-standard connection.

Here is the motherboard I am using:
http://www.newegg.com/Product/Product.aspx?Item=N82E16813130082

saleem
04-07-2011, 06:22 PM
jungleflasher user guide should give you most if not all the info you require.
:)