SuperCard DSTWO FW v1.15 released (3DS v4.0.0-7x compatible)

Discussion in 'Underground Nintendo Scene' started by GaryOPA, Apr 26, 2012.

By GaryOPA on Apr 26, 2012 at 11:24 AM
  1. 22,264
    1,951
    113
    GaryOPA

    GaryOPA Master Phoenix Admin Staff Member Top-Dog Brass

    Joined:
    Mar 18, 2006
    Media:
    115
    Occupation:
    Design Eng.
    Location:
    Tropical Island
    Home Page:
    It didn't took too long.

    [​IMG]

    SC just released a new firmware that support both DSi 1.44 and the latest 3DS 4.0.0.7!

    The SuperCard team, just released a new Firmware version for their DSTWO. v1.15 is now compatible with both DSi 1.44 and the new 3DS 4.0.0.7, which was just released yesterday.

    Here are the upgrade instructions:

    Download it on the official SC website linked below!

    OFFICIAL SITE: http://eng.supercard.sc/manual/dstwo/download.htm

    NEWS SOURCE: http://www.gbarl.it/index.php?showtopic=82269

    Our thanks to 'Gauss' for this 'flashcart' news update!
     

Comments

Discussion in 'Underground Nintendo Scene' started by GaryOPA, Apr 26, 2012.

    1. 26,565
      169
      63
      Xenogears V

      Xenogears V Senior Helper Staff Member Clean-Up Crew

      Joined:
      Dec 28, 2006
      Location:
      Italy Rulez! - Proud To Italian
      For an instant I thought was a 3ds flash card. :p
       

Share This Page