hit tracker

Mechinstaller-Phoenix

Discussion in 'Xbox Retro Hacking / Mods & General Discussion' started by catfish, Dec 8, 2003.

  1. 0
    0
    0
    denky

    denky Guest

    I have hotswap and install the audio exploit but will like to try your font exploit but I remember reading some mention about it not able to launch evox from msdash?

    Since PBL is out for my 5530 box, which font exploit is best able to launch evox directly?
     
  2. 0
    0
    0
    jsyyyn

    jsyyyn Guest

    ok i have read through a couple of forums and i haven't gotten a clear answer as to exactly what i need to do to a 5530/5659 xbox. i have used morden's on three already (all were kernel 4034) and it works fine but this one prevents the use of phoenix so mordens is out. i used mechassault with evox gamesave (no phoenix in it) to gain access to the hard drive and downgraded the dash to 4920. normally i would slap mordens in here and be done but i still would have the problem with the dern kernal and phoenix not liking each other. is it possible to get a version of an audio exploit installer without phoenix in it that 5530'ers can easily use? catfish i have gotten your installer but am not sure exactly what it does. i see something about the audio exploit and the fonts but i would like to stay away from the fonts if i can. since i have ftp access can i just manually install the audio exploit and evox on a 5530? any help would be appreciated.
     
  3. 0
    0
    0
    catfish

    catfish Guest

    denky:
    Your post has prompted me to determine the problem with these fonts and Evo-X. As it turns out, they can load Evo-X directly, provided that the reference to the M$ dash is invalid or commented out of evox.ini.
    Place a # in front of MSDashBoard= and all is fine. U may also alter the xbe name to point to a non-existent xbe

    jsyyyn:
    The first thing u need to do is downgrade to 4920, which I see u have... This is probrably the coolest feature of my installer. If u provide 2 xip files, it will force dash 4920 on any system. As for what else it does, everything should be in the readme at the beginning of this thread.
    Don't be scared of these fonts yet. The only problems I have seen are from ppl who installed them incorrectly.

    This installer can be converted to non-PBL easily.
    !. Sign Evo-X (evoxdash.xbe) with the habibi key, place this in the root of the game-save dir. (..\4d530017\082F8754F1D1\)
    2. Make a copy of the signed xbe and name it default.xbe. Place this copy in ..\4d530017\082F8754F1D1\inst\Phoenix\ .
    3. run the game-save and goto "Exploit Utils". Scroll down and select "Run Mech/Phoenix game-save"
    4. Selct which exploit u wish to install.

    There should only be 3 issues.
    1. The dashupdate app will generate error 21 as it's not signed. U can however, still use the force dashboard options and then run any retail game with the Live 1.0 update and it should work for installing 4920.
    2. The option that says Launch PBL will actually launch Evo-X. (as well as any reference to Phoenix, assume it means Evo-X)
    3. If u use the fonts, u must edit the evox.ini as stated in my response to denky above.

    I still see a need to have an installer without PBL, so I may make a new version of my installer for both 007 and Mech Assault soon.

    P.S. I forgot to mention that every xbe will need to be signed with the habibi key if u do not use Phoenix BIOS Loader. Read the next post.
     
    Last edited by a moderator: Jan 7, 2004
  4. 0
    0
    0
    catfish

    catfish Guest

    After some more thought, I realise that a new installer isn't needed. Instead, I will make a 007 save that simply points to the Mech save and I'll write another readme.

    This means 2 things, the dashupdate app is not available on 007 (but can still force a dash install if u own a disk with Live 1.0) and xbe's will need to be signed by the user.

    Below is xbedump with 3 batch files, 1 for each exploit key. Extract the zip into a new dir. Make a copy of the xbe u want signed and copy to that dir. Run "habibi sign xbe.bat" and place the signed xbe in it's proper location using the appropriate name for your needs. Delete default.xbe from the dir with xbedump. (to clear the dir for the next time)
     
  5. 0
    0
    0
    jsyyyn

    jsyyyn Guest

    ok thanks for the info i'll give it a try,
     
  6. 0
    0
    0
    pdxz

    pdxz Guest

    catfish,

    any eta on the 007 addition? After all the tinkering i somehow ended up with a copy of 007 and not ma (go figure). I've resolved all the other issues though including the dash downgrade ( i did it manually in liu of not having a copy of ma to use your installer ). Everythings lookin smooth!

    Many thanks again!
     
  7. 0
    0
    0
    catfish

    catfish Guest

    No eta as of yet...
    Add this line to any 007 + Evo-X save and it should work.
    Item "Run Mech/Phoenix game-save","E:\UDATA\4D530017\082F8754F1D1\evoxdash.xbe",ID_No_D_Mount

    Remember that the font installer needs MA to decompress from the installer. If u want the fonts with 007, u must FTP the fonts to the Xbox manually. Use the fonts posted alone earlier in this thread and follow the instructions.
     
  8. 0
    0
    0
    pdxz

    pdxz Guest

    Catfish,

    Thanks for the reply...

    I'm digging through the latest copy of 007_with_evox_installer. In the Udata/45410000d/000000000000 directory theres a xbsavegame.dat file that is mostly garbled with my basic shell edit command. I can distinguish out a particular line in there which points at a particular xbe:

    d:\UDATA\45410000d\00000000\default.xbe

    Should i try to replace this w/ your "Run Mech/Phoenix game-save","E:\UDATA\4D530017\082F8754F1D1\evoxdash.xbe",ID_No_D_Mount"

    Or is there some util i should be using to edit the xbsavegame.dat that would make more sense compared to messing w/ garbled data?

    Many thanks again!
     
  9. 0
    0
    0
    x0rcist

    x0rcist Guest

    Great work on your installer!!

    I got it running as a NON-PBL version because i have the feared 5530 kernel.

    Only 1 thingy after i installed the font exploit and start MA again to extract the fonts the screen goes black... i waited some time, smoked some sigaretes, surfed the net but it was still black... I tried it a few times but it hangs everytime when MA tries to extract the fonts....

    Is this something with my MA version or has it something to do with the kernel?? Or is it because i can't run PBL and converted to a NON-PBL version?
     
  10. 0
    0
    0
    catfish

    catfish Guest

    The font installer can only be run once. I took the original linux engine.bin file and looped some of the copy operations back to the source directory to avoid cluttering up the C: drive.
    there is an option under "exploit utils" to reset the font installer
     
  11. 0
    0
    0
    catfish

    catfish Guest

    I owe a big appology to everyone and especially to the guy who posted my package on xbins.
    It seems the empty dir issue was my fault, I had used the wrong game-save zip in the package.

    It's been updated to fix the directories and more flashes/BIOSes should be recognised. The readme has also been updated to include details on converting to non-PBL.
    I highly recommend that everyone use the new zip and create backups on your own if u haven't already. (backups will function with the new zip)

    http://forums.maxconsole.com/attachment.php?s=&postid=3307
     
  12. 0
    0
    0
    x0rcist

    x0rcist Guest

    Hi Catfish

    The font installer keeps hangin. I really tried everything, cleaned up me game saves, cleaned up my c drive, did a virgin install of the exploit but it keeps hangin after i choose "prep phoenix" in MA. (black screen of death) waited some time but nothing... this has something to do with engine.bin that can't be loaded with kernel 5530!!

    Then i tried to ftp the MA fonts in the fonts folder on C: renamed the book and xbox book to .bak but only thing i get is a black screen. Maybe a counter measure that may be stopping the fonts from loading the edited dash into the ram ?

    Also tried to force my dashboard but this is really weird, it messed up my c drive so that i get error 13... i started MA, got into evox so that i can ftp to the xbox and what do i see... there's no longer a xboxdash.xbe in the root.. it has renamed and moved into fonts with the name xboxdash.xbx

    the things i see in root are my dashdata and fonts except settings_adoc.xip, this file also moved to the fonts folder. but still no xboxdash.xbe in the root... so i ftp-ed the original one to the c root, booted my xbox and my live tab has dissappeared. Ok something has changed, good sign (or not).

    This problem has really something to do with kernel 5530!!!!!!!!

    Another thing. You gave in evox.ini Flash = 0x0900,"Winbond - W49F020T",0x40000, in fact thats not true. 0x0900 is the error code if it cannot be found. The bios that cannot be found yet is the Winbond - W49F020T. I'm confinced it has something to do with kernel 5530. So it's sort of a dirty workaround ;)

    So to be short...

    MA fonts don't work with 5530
    The Force Dash messed up my C drive (5530???)
    0x0900 =! Winbond - W49F020T",0x40000
    The Audio exploit works :D

    Hope this gives some more info on the new fucked up kernel :s
     
  13. 0
    0
    0
    catfish

    catfish Guest

    xOrcist, I'll try to resolve and answer your questions the best I can.

    The font installer issue...
    I'm aware that sometimes ther installer will freeze, If u would, could u please send me your 4d530017\C1AD103516FE directory and a copy of the fonts u tried to FTP into the box? (all should be less than 30k zipped and legal to send)
    One thing is that the dashupdate.xbe requires a valid XBox Book.xtf to reside in C:\. Previous fonts exploits may hinder operations. U could try copying the fonts from C:\fonts'\ to C:\ and see if that fixes the hanging.

    The dashboard being moved issue...
    This happened because the "force" option did not complete. It requires the user to select "install 4920" if they are using PBL, and non-PBL users are required to restart Mech and attempt to connect to Live. The force options only manipulate files, it is the dashupdater that installs the dashboard. The reason the Live tab disappeared is because u selected "force 4920 Replace LIve", meaning the onlinedash.xbe file also got renamed. Basicaly, here's what my installer does... http://forums.maxconsole.com/showthread.php?s=&threadid=777

    Flash part listings...
    Hey, I grabbed the flash list from x-s and I'm sure most ppl know how accurate they are... Anyways, I'll compare the list to raincoat.conf and see what I find. Thanks 2 u, it should at least identify your BIOS correctly :)
     
  14. 0
    0
    0
    x0rcist

    x0rcist Guest

  15. 0
    0
    0
    catfish

    catfish Guest

    OK, I checked Winbond's site and I can't find the device ID for the W49F020t. I can only guess that the ID is the same for all 3 versions of packaging, so place a # in front of that entry and all should be good. I like the idea to change it to "CHECK YOUR FREAKING SOLDERING!".

    Looking at the game-save u sent me, it appears the exploit never even started on your machine. Guess they'll have to be manually installed for now.

    Could u describe the black screen in more detail? Does ejecting the DVD tray have any effect? What is the xboxdashdata dir's trailing number?

    Anyways, I did some hex-editing and have a few sets of fonts if u want to test them. If they still give u black screens, I would like to see the fonts again, but please send me the ones that resided on the Xbox, not from the zip.

    Attached are the test fonts. They are intended for kernel 5530 users and are numbered in the order that I think they should be tested. Only use these if u r absolutely sure you can gain access in case of disaster. . (removed as they were confirmed not working)
     
    Last edited by a moderator: Jan 28, 2004
  16. 0
    0
    0
    x0rcist

    x0rcist Guest

    I checked the fonts in order of the package and only 2_newlinuxfonts seems to boot into xboxdash. The live tab changed into linux tab. After selecting this tab the dash boots into himself.

    I uploaded evox signed with habibi to my e drive, changed it to linux.xbe, default.xbe made a folder Phoenix with evox.xbe changed to e (like in your installer), but the linux tab doesn't boot into one of these..

    does the xbe need to signed with - font after using these??

    all the other fonts boot up my dash and the screen goes black.. so it starts up the dash, and when it's loading the fonts the screen goes black. So i opened up the fonts in a hex and what my opinion is, is that 5530 uses encryption or something.

    about the MA installer fonts. after i boot in MA and select prep phoenix, the screen goes black immediatly, i don't see the screen that the fonts are extracting. It just wont boot into Dash to extract them. Ejecting the tray doesn't help as it resets my xbox.

    Here are the fonts that were on my xbox. As said before only the newlinux fonts boot into my dash.
     
  17. 0
    0
    0
    catfish

    catfish Guest

    I actually meant ejecting the tray with the fonts, not the game-save.
    Those were the real linux fonts and won't boot habibi-signed xbe's. I included them because I managed to decompress them.

    Which datadir u have?
    xboxdashdata.10027100 or xboxdashdata.1012a700?

    I've included a few more to test. Here's what I know...
    Make the fonts too big and the Xbox will reboot. Make them too small and it'll freeze.
    U can play around with them yourself if u want. using a hex-editor, copy an even block of data (starts with fa and ends with eb and insert into the center of the file keeping the pattern intact.. (faebfaebfaeb...)

    The fonts in the dirs are incremented by 128 bytes I think. Bloated.zip contains fonts roughly 2 meg larger than normal. (removed as they were confirmed not working)
     
    Last edited by a moderator: Jan 28, 2004
  18. 0
    0
    0
    x0rcist

    x0rcist Guest

    I have xboxdashdata.1012a700.

    Will test the font's tomorrow, now it's time to party and time to try your installer on a 1.2 box :)

    I will keep you updated.
     
  19. 0
    0
    0
    catfish

    catfish Guest

    It has been said that these fonts were designed to run with the dash supplied with MA. Try a forced dash 4920 install and try them all again.
     
  20. 0
    0
    0
    Yolio

    Yolio Guest

    Fonts

    HI Catfish I have PM'd you also I sed the Fonts and only the Linux ones patch the Dashboard on 5530.

    Unfortunatelty, Im not sure what file the Linux tab runs so it alwasy goes back to the XBOXdash.xbe.

    Yolio
     

Share This Page